mersenneforum.org

mersenneforum.org (https://www.mersenneforum.org/index.php)
-   YAFU (https://www.mersenneforum.org/forumdisplay.php?f=96)
-   -   YAFU 2.0 (https://www.mersenneforum.org/showthread.php?t=26681)

storm5510 2022-09-06 23:17

[QUOTE=James Heinrich;612807]"i7" and "Xeon" are both nebulous descriptors that could describe any number of CPUs over decades. Perhaps specific model numbers would provide more of a clue as to perhaps which features are not supported on your "Xeon".[/QUOTE]

E5-1620 Sandy Bridge EP.

Version 1.34.5 runs without issues. Nothing later will.

kotenok2000 2022-09-07 09:00

[url]https://www.cpu-world.com/CPUs/Xeon/Intel-Xeon%20E5-1620.html[/url]
Maybe it requires avx2?

bsquared 2022-09-07 17:47

It should work on systems without AVX2, but I don't have any of those to test on anymore, so apparently it doesn't. Based on where it crashes it would seem the problem lies in the ysieve library, since one of the first things yafu does is create and store a small list of primes.

kruoli 2022-09-07 18:12

Yes, I have analyzed this before: :smile:

[QUOTE=kruoli;589431]When running the current build on GIT on an Ivy Bridge processor, I get an invalid instruction error (MULX, since Ivy Bridge does not support BMI(2)) at 0x000000013F571B43. This happens when the prompt ([C]>> [/C]) is already displayed. Is the processor too old to be supported out of the box?[/QUOTE]

James Heinrich 2022-09-07 20:52

1 Attachment(s)
I know my [url=https://www.cpu-world.com/CPUs/Core_i7/Intel-Core%20i7-3930K.html]i7-3930K[/url] (also Sandy Bridge) doesn't run YAFU 2.x, but I had always assumed that was Windows-7 thing. I guess it's (also?) a hardware thing.

(is it sad that my main daily system is nearing 11 years old? :paul:)

kruoli 2022-09-07 21:38

[QUOTE=James Heinrich;612905](is it sad that my main daily system is nearing 11 years old? :paul:)[/QUOTE]

No, I won't give up on my one voluntarily!

storm5510 2022-09-08 15:54

[QUOTE=James Heinrich;612905]I know my [url=https://www.cpu-world.com/CPUs/Core_i7/Intel-Core%20i7-3930K.html]i7-3930K[/url] (also Sandy Bridge) doesn't run YAFU 2.x, but I had always assumed that was Windows-7 thing. I guess it's (also?) a hardware thing.

(is it sad that my main daily system is nearing 11 years old? :paul:)[/QUOTE]

Only my i7-7700 is AVX2. The Xeon and i5 are not. These two date back to 2012. The i7 is four years old, (2018). I sourced the parts and built it myself. The Xeon can run Windows 10 or Ubuntu 20.04. I doubt the i5 could run Windows 10. It runs Windows 7 well enough.

kotenok2000 2022-09-19 19:20

My amd fx 6100 ran windows 10

wombatman 2022-09-20 04:27

I'm running into the following error while trying to compile the latest YAFU:

[CODE]/usr/bin/ld: ./libysiqs.a(SIQS.o): in function `siqs_static_init':
/home/wombat/yafu/factor/qs/SIQS.c:2309: undefined reference to `nextRoots_32k_avx2_intrin'[/CODE]

Compilation instruction is "make USE_AVX2 NFS=1". Everything else seems to be building properly as the above is the only error.

bsquared 2022-09-20 13:10

[QUOTE=wombatman;613736]I'm running into the following error while trying to compile the latest YAFU:

[CODE]/usr/bin/ld: ./libysiqs.a(SIQS.o): in function `siqs_static_init':
/home/wombat/yafu/factor/qs/SIQS.c:2309: undefined reference to `nextRoots_32k_avx2_intrin'[/CODE]

Compilation instruction is "make USE_AVX2 NFS=1". Everything else seems to be building properly as the above is the only error.[/QUOTE]

You'll need to add USE_BMI2=1 to the make line as well. Most cpu's that have avx2 also have bmi2... if yours doesn't then you'll have to remove both the avx2 and bmi2 options.

richs 2022-11-13 22:34

I sieved an Aliquot C141 using Yafu 2.0 and when the filtering ran, every relation was an error -11. Looking at the .fb file below, somehow Yafu did not include skew, rlim, frmax, famax, srlpmax, or salpmax.

[CODE]N 379940961516713825613865981760557035526784109230555165792877792447392213895676955608876175676740458184733360391979563490370537264576678836483
A0 17921599049871804734714330370707400
A1 884689986849071910726068107020
A2 1004298442072520798460436
A3 -54583391456339434
A4 -93062625051
A5 9180
R0 -2105596592265349121584460471
R1 1152139905935473[/CODE]

I got it to work by adding skew and the other parameters to the .fb file and running Yafu 1. I'm not sure if this was my error or if Yafu 2.0 did not include the parameters for some odd reason.


All times are UTC. The time now is 19:55.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.